GitLab Documentation

Updating GitLab via omnibus-gitlab

Documentation version

Please make sure you are viewing this file on the master branch.

Updating from GitLab 6.6 and higher to 7.10 or newer

See doc/update/README.md.

Updating from GitLab 6.6 and higher to the latest version

See doc/update/README.md.

Updating from GitLab 6.6.0.pre1 to 6.6.4

See doc/update/README.md.

Reverting to GitLab 6.6.x or later

See doc/update/README.md.

Upgrading from a non-Omnibus installation to an Omnibus installation

See doc/update/README.md.

Upgrading from non-Omnibus PostgreSQL to an Omnibus installation using a backup

See doc/update/README.md.

Upgrading from non-Omnibus PostgreSQL to an Omnibus installation in-place

See doc/update/README.md.

Upgrading from non-Omnibus MySQL to an Omnibus installation (version 6.8+)

See doc/update/README.md.

RPM 'package is already installed' error

See doc/update/README.md.

Updating GitLab CI via omnibus-gitlab

Updating from GitLab CI version prior to 5.4.0 to the latest version

See doc/update/README.md.